巴啦啦 巴啦啦

我们在这里介绍下咱们好伙伴 Composer

请Composer登场。。。你先自我介绍下吧

:我叫 坑木泡涩 我是一个包管理工具 我管理的包包都来自 https://packagist.org/里面

:哦 泡涩君 你最近晒黑了。。。

接下来我们正式介绍下Composer

composer 配置项
ID 配置项 说明
1 name 包的名称,它包括供应商名称和项目名称,使用 / 分隔。
2 description 包描述
3 version 版本
4 type 安装类型
5 keywords 关键字
6 homepage 项目主页
7 time 版本发布时间
8 license 许可协议
9 authors 作者
10 support 支持,获取项目支持的向相关信息对象。
11 require 自动加载的包
12 require-dev 在 DEV 下自动加载的包
13 conflict 此列表中的包与当前包的这个版本冲突。它们将不允许同时被安装
14 suggest 建议安装的包,它们增强或能够与当前包良好的工作。这些只是信息,并显示在依赖包安装完成之后,给你的用户一个建议,他们可以添加更多的包。
15 autoload 自动加载,分别有四种加载机制 psr-4 psr-0 classmap file
16 include-path 保留传统,不建议使用
17 target-dir 定义当前包安装的目标文件夹
18 minimum-stability 安装包的时候通过稳定性过滤包的默认行为,dev alpha beta RCstable 可选
19 prefer-stable 安装包的时候优先使用更稳定的包版本,”prefer-stable”: true
20 repositories 使用自定义的包资源库。默认情况下 composer 只使用 packagist 作为包的资源库。通过指定资源库,你可以从其他地方获取资源包。
21 config 配置参数,eg:process-timeout vendor-dir
22 scripts Composer 允许你在安装过程中的各个阶段挂接脚本。
23 extra 任意的,供 scripts 使用的额外数据。
24 bin 该属性用于标注一组应被视为二进制脚本的文件,他们会被软链接到(config 对象中的)bin-dir 属性所标注的目录,以供其他依赖包调用。
25 archive 这些选项在创建包存档时使用。

开发种配置详细说明

1.require

标识符 含义 实例
>=1.0 范围 这个很好理解就不说了
* 通配符 1.0.*相当于>=1.0 <1.1
^ 安装的最新版本 “barryvdh/laravel-cors”: “^0.10.0” 安装 laravel-cors 最新版本
~ 标识安装的最后一位区间版本 “barryvdh/laravel-cors”: “~0.10.0”, 安装 laravel-cors 0.10.0-0.10.9

2.require-dev

  1. composer install 会安装 require-dev 中的包,require 中的包
  2. composer install —no-dev 只会安装 require 中的包

3.scripts

"scripts": {
    "post-autoload-dump": [
        "Illuminate\\Foundation\\ComposerScripts::postAutoloadDump",
        "@php artisan package:discover --ansi"
    ],
    "post-root-package-install": [
        "@php -r \"file_exists('.env') || copy('.env.example', '.env');\""
    ],
    "post-create-project-cmd": [
        "@php artisan key:generate --ansi"
    ]
}
scripts 是自定义执行 SHELL 命令,如上代码中,执行 post-root-package-install 执行复制文件。

4.autoload

PHP 自动加载文件,分别有四种加载机制 psr-4 psr-0 classmap file
修改完 autoload 的内容之后要记得执行 composer dump-autoload 来重新生成加载文件
这四种匹配机制会生成 autoload_classmap.php autoload_namespaces.php autoload_files.php 中间中对应关系
psr这个东西以后咱们会细说哒

命令详解

1.composer install

这个很重要哟,先安装 composer.lock 文件中 packages 中的版本;即使 composer.json 与 composer.lock 中版本不一致

2.composer update

这个也很重要哟,先安装 composer.json 的版本,并且更新 composer.lock 中 packages 中的版本

3.composer dump-autoload

CMD 说明 应用场景
composer dump-autoload 打印自动加载索引,就是将 autoload 中的各项加载到本该指定的目录。 开发环境 你更新了 autoload 中的各项
composer dump-autoload -o 转换 PSR-0/4 autoloading 到 classmap 获得更快的载入速度 适用于生产环境
composer dump-autoload -o —no-dev 禁用 autoload-dev 规则 适用于生产环境
composer dump-autoload —classmap-authoritative 只加载 ClassMap 中的文件,必到磁盘文件系统进行任何检查 适用于生产环境

Source: https://www.bigran.cn/article/pB3DoAKr.html

Leave a comment

Published

2019-05-25 11:41:04


Categories


Tags

友情链接

分享代码